Classic More »

SkyBlock More »

Eden More »

IC2-S1 More »

IC2-S2 More »

SkyTech More »

Creative More »

Vanilla More »

 

Eden update 1904

Byl proveden menší bugfix update serveru Eden. Pusťte si tedy instalátor, zaktualizuje vám módy.

IC2 update 1504

Aktualizujte si módy serverů IC2 S1,S2 – stačí pustit jen instalátor. Byly opravené např. recepty na solární helmy.

Videonávod jak nainstalovat modpacky

Hráč MiraSuja pro ty z Vás, kteří máte potíže s instalací modpacků do verze 1.6, natočil krátký tutoriál (návod):

Děkujeme a věříme, že alespoň nekomu pomůže.

Informace o módovaném Minecraftu 1.7

Verze Minecraftu 1.7 je tu již velmi dlouho a řadu z Vás by určitě zajímalo, jaký je stav módované verze. Jistě si vzpomínáte jak oproti předchozím verzím dlouho trvalo, než vyšel jen obyčejný nemódovaný plnohodnotný bukkit server pro verzi 1.7.2. Za další a delší dobu teprve vyšla první verze Minecraft Forge – nedílná součást módování a nakonec i první verze módovaného MCPC+ serveru. Vývojáři těchto projektů to tentokrát neměli vůbec lehké a proto aktualizace mezi 1.6.4 a 1.7.2 trvaly tak dlouho.

Verze 1.7 není jen o přidání nových biomů, bloků a itemů, ale z programátorského hlediska došlo “pod kapotou” k velkému množství změn. Řada těchto změn ukazuje na fakt, že Mojang konečné skutečně pracuje na slibovaném Modding API, což je rozhraní pro vývojáře všemožných modifikací. Jako jednu z věcí bych “vypíchnul” např. to, že módy v 1.7 již ve svých konfiguracích nemají číselné ID:DATA pro bloky a itemy. Odstranění nutnosti číselných ID zjednoduší tvorbu modpacků a taktéž přechody mezi verzemi. Tato změna samozřejmě přináší nutnosti změn v řadě pluginů pro módované servery. Výhodou bude, že např. u tabulkového shop pluginu uvidíte místo nápisu X246 třeba Solar Panel. V aktuální verzi serveru 1.7 je tato vlastnost téměř kompletně implementována.

Tady se dostáváme k tomu, že zjistíte, že módovaný server verze 1.7 není zdaleka připraven pro použití na veřejném serveru, jakým bezesporu B-Paradise je. Velké množstí základních funkcí není zcela dokončeno a odladěno, mnoho pluginů s módovaným serverem nefunguje – většinou je chyba z důvodu chybějící třídy či metody. Neméně důležitým faktem je nyní několikatýdenní přestávka vývojářů serveru – hromadí se tikety, které nejsou řešeny a vůbec nevychází nové buildy serveru. Když porovnám situaci s předchozí verzí, kdy verze buildu rozumné stabilní verze měla číslo 189 (jistě vzpomínáte na chybu s tekoucí vodou na skytechu) a u verze 1.7 je teprve 51, osobně tuto verzi nepovažuji za vhodnou pro nasazení na produkčním serveru.

Neméně závažným problémem módované verze 1.7 je i chyba v Minecraft Forge, kdy při změnách modpacku (změny alokace blok/itemů při odebrání/přidání módu/modů) dojde k nekonzistenci nebo chcete-li poškození již vygenerovaného světa (dá se to samozřejmě komplikovaně opravit). Minulá verze (1.6.4) díky číselným ID s tím něměla problémy. Všechny chyby jsou nahlášeny a dozajista budou brzy opraveny.

Závěrem bych tedy řekl jen to, že verze 1.6.4 bude na serverech ještě dlouho, protože nemá smysl vrhat se do nestability a nedodělků.

Nové Challenge pro SkyTech

Ahoj lidičky. Rádi bychom Vám dali prostor na vyjádření nápadu pro SkyTech. Napadají vás nové challenge? Nebojte se a napište je zde do komentáře.

Globální pád serverů

Kvůli chybě v kódu módovaných/nemódovaných serverů došlo k pádu velkého množstí minecraftových serverů (celosvětově). Autoři zareagovali naštěstí pohotově a vydali opravu. Naše servery již běží v pořádku. Děkujeme za pochopení.

Eden update 1803

Aktualizoval jsem módy serveru Eden, protože díky chybám v nich server poměrně často padal. Nové verze by měly situaci zlepšit.

Stačí, když pustíte instalátor, zaktualizuje vám módy.

Uzavření PvP serveru

Vzhledem k nezájmu o PvP server jej uzavíráme.

Doktor svolává:-)

Prosím všechny buildery a případně moderátory, kteří umějí pěkně stavět ať se mě ozvou na tsku :-) děkuji

Linux/Mac OSX verze instalátoru

Inženýr SprtCz, kterého znáte z IC serverů, připravil verzi instalátoru pro operační systémy Linux a Mac OSX. Instalátor je naprogramován v jazyce Python, konkrétně vyžaduje verzi 2.7.

Věříme, že instalátor ocení všichni, kdo nepoužívají Windows. Díky!

Instalátor je ke stažení v sekci Download.

snowflake snowflake snowflake snowflake snowflake snowflake snowflake snowflake snowflake snowflakeWordpress snowstorm powered by nksnow